Sector Offline
Incident Report for Big Blue Rocket
Resolved
This incident has been resolved.
Posted Feb 22, 2020 - 22:00 GMT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 22, 2020 - 19:48 GMT
Investigating
We have been made aware of issues connecting to our sector in Thulston. We're investigating currently.
Posted Feb 22, 2020 - 15:43 GMT
This incident affected: Elvaston Parish (Thulston).