Jubilee Sector - Disconnections
Incident Report for Big Blue Rocket
Resolved
This incident has been resolved.
Posted 3 months ago. May 14, 2019 - 17:16 BST
Identified
We have been made aware of disconnections from our service and are aware of an issue arising from our maintenance yesterday. We are working to implement a fix.
Posted 3 months ago. May 14, 2019 - 12:07 BST
This incident affected: Derby City (Ascot Drive Industrial Estate).